NumberingSchemaType Class


Numbering Schema Type Class

A type for identifying a NumberingSchema of a particular kind.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB GuidEnum
Autodesk.Revit.DB NumberingSchemaType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class NumberingSchemaType : GuidEnum

The NumberingSchemaType type exposes the following members.

Constructors
Name Description
Public method NumberingSchemaType Creates a new NumberingSchemaType instance.
Top
Properties
Name Description
Public property Guid The Guid of GUID-based enum object.
(Inherited from GuidEnum )
Top
Methods
Name Description
Public method Equals Compares two Guid-based enum object based on their concrete class and GUID value.
(Inherited from GuidEnum )
Public method GetHashCode Generates a hash code for this Guid-based enum object.
(Inherited from GuidEnum )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Operators
Name Description
Public operator Static member Equality(NumberingSchemaType, NumberingSchemaType) Compares two NumberingSchemaType instances.
Public operator Static member Inequality(NumberingSchemaType, NumberingSchemaType) Compares two NumberingSchemaType instances.
Top
Remarks

Each numbering schema is applicable to a certain category of Revit elements. For example, the Rebar numbering schema (built-in) is used and only applicable to Rebar elements. With that schema present, all Rebar elements automatically will get their respective numbers and those numbers would not correspond in any way to numbers of other enumerable elements that belong to different numbering schemas.

There are only built-in schemas available currently.

See Also