Compound |
Creates a CompoundStructure containing a single layer.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static CompoundStructure CreateSingleLayerCompoundStructure(
MaterialFunctionAssignment layerFunction,
double width,
ElementId materialId
)
Parameters
- layerFunction MaterialFunctionAssignment
- The function of the single layer.
- width Double
- The width of the single layer.
- materialId ElementId
- The ElementId of the material for the single layer.
Return Value
CompoundStructureThe newly created compound structure.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
ArgumentOutOfRangeException | The given value for width must be greater than 0 and no more than 30000 feet. -or- A value passed for an enumeration argument is not a member of that enumeration |

It is not verified that materialId corresponds to a valid Material element.