PathType Enumeration


Path Type Enumeration

Enum determining what kind of path a given external file reference path is. Paths are valid for all types of external file references unless otherwise specified.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum PathType
Members
Member name Value Description
Absolute 1 The path is an absolute path to a location on disk or the network.
Content 3 The path is relative to a location in the Revit content libraries. This value is only valid for ExternalFileReferenceType.KeynoteTable, ExternalFileReferenceType.AssemblyCodeTable or ExternalFileReferenceType.Decal.
Relative 0 The path is relative to the host file's location, or to the central model's location if the host is workshared.
Server 2 The path is to a Revit Server location. This value is only valid for ExternalFileReferenceType.RevitLink.
See Also