Simplify Method


Toposolid Simplify Method

Simplifies the toposolid by reducing the number of inner vertices to the given percentage.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void Simplify(
	double percentage
)

Parameters

percentage Double
The ratio of the number of inner vertices after simplify to the original number.
Exceptions
Exception Condition
ArgumentException The input percentage should be greater than 0 and less than 1.
InvalidOperationException this operation failed.
Remarks
At low percentages, the inner vertices may not be reduced to the exact percentage to keep a rough semblance of the original shape. Call this method again if you want to keep removing inner vertices.
See Also