SketchedStairsCurveData Class


Sketched Stairs Curve Data Class

Sketched run/landing curves overrides with height and slope
Inheritance Hierarchy
System Object
Autodesk.Revit.DB SketchedStairsCurveData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class SketchedStairsCurveData : IDisposable

The SketchedStairsCurveData type exposes the following members.

Constructors
Name Description
Public method SketchedStairsCurveData Construct a SketchedStairsCurveData defined by a curve associated with its height and slope type.
Top
Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the SketchedStairsCurveData
Public method GetCurve Get a copy of the curve that is formed along this boundary.
Top
See Also