AddCopyAsConnectedAsset Method


Asset Property Add Copy As Connected Asset Method

Makes a copy of the asset and connects it to this property.

Namespace: Autodesk.Revit.DB.Visual
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public void AddCopyAsConnectedAsset(
	Asset pRenderingAsset
)

Parameters

pRenderingAsset Asset
The asset to duplicate and associate with this property as a connected asset.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
InvalidOperationException The asset property is not editable. -or- Cannot check validity for a property not being edited in AppearanceAssetEditScope. -or- Asset property is already connected to one asset.
See Also