CreateInstanceView Method (Document, ElementId)


Panel Schedule View Create Instance View(Document, Element Id) Method

Creates a new instance of this view (using default template)

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static PanelScheduleView CreateInstanceView(
	Document ADoc,
	ElementId panelId
)

Parameters

ADoc Document
The Document
panelId ElementId
Element id of the electrical panel element.

Return Value

PanelScheduleView
The PanelScheduleView
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also