CreateNoteBlock Method


View Schedule Create Note Block Method

Creates a note block.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static ViewSchedule CreateNoteBlock(
	Document document,
	ElementId familyId
)

Parameters

document Document
The document to which the new schedule will be added.
familyId ElementId
The ID of the family whose elements will be included in the schedule.

Return Value

ViewSchedule
The newly created schedule.
Exceptions
Exception Condition
ArgumentException document is not a project document. -or- familyId is not a valid family for a note block.
ArgumentNullException A non-optional argument was null
ModificationForbiddenException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException The document has no open transaction.
Remarks
A note block is a schedule of the Generic Annotations category that shows elements of a single family rather than all elements in the category.
See Also