IDuctFittingAndAccessoryPressureDropServer Interface


IDuct Fitting And Accessory Pressure Drop Server Interface

Interface class for external servers implementing duct fitting and duct accessory coefficient calculation.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public interface IDuctFittingAndAccessoryPressureDropServer : IExternalServer

The IDuctFittingAndAccessoryPressureDropServer type exposes the following members.

Methods
Name Description
Public method Calculate Calculate the duct fitting and duct accessory coefficient.
Public method GetDataSchema Obtains the schema of the ESEntity.
Public method GetDescription Implement this method to return a description of the server.
(Inherited from IExternalServer )
Public method GetName Implement this method to return the name of the server.
(Inherited from IExternalServer )
Public method GetServerId Implement this method to return the id of the server.
(Inherited from IExternalServer )
Public method GetServiceId Implement this method to return the id of the service.
(Inherited from IExternalServer )
Public method GetVendorId Implement this method to return the id of the vendor of the server.
(Inherited from IExternalServer )
Public method IsApplicable Check if the server is applicable for the duct fitting or duct accessory.
Top
Remarks
A typical way to use the external server can be:
  • Implement a server class that derives from this interface
  • Create a new server object and register it with the service, see ExternalServiceRegistry .
  • Assign server to duct fitting instance.
See Also