Autodesk.Revit.Creation Namespace


Autodesk. Revit. Creation Namespace

Classes
Class Description
Public class Application The Application Creation object is used to create new instances of utility objects.
Public class AreaCreationData A class which wraps the arguments of Area for batch creation
Public class Document The Document Creation object is used to create new instances of elements within the Autodesk Revit project.
Public class FamilyInstanceCreationData A class which wraps the arguments of FamilyInstance for batch creation.
Public class FamilyItemFactory The Family Item Factory object is used to create new instances of elements within the Autodesk Revit Family.
Public class ItemFactoryBase The ItemFactoryBase object is used to create new instances of elements within the Autodesk Revit document.
Enumerations
Enumeration Description
Public enumeration eRefFace Indicates the reference face. The Opening will be created at the direction perpendicular to the reference face.