Analytical |
Get the electrical connected phases of the downstream node.
Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- id ElementId
- The downstream node id.
Return Value
ElectricalConnectedPhasesThe electrical connected phases of the downstream node.

Exception | Condition |
---|---|
ArgumentException | The id isn't a downstream node id of the power distributable node. |
ArgumentNullException | A non-optional argument was null |

If node B supplies from node A, node B is the downstream node of node A, and node A is the upstream node of node B. Usually one node may have many downstream nodes, but TransferSwitch can only have one downstream node.