FamilyInstanceCreationData Constructor (Face, Line, FamilySymbol)


Family Instance Creation Data(Face, Line, Family Symbol) Constructor

Initializes a new instance of the FamilyInstanceCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public FamilyInstanceCreationData(
	Face face,
	Line position,
	FamilySymbol symbol
)

Parameters

face Face
A face of a geometry object.
position Line
A line on the face defining where the symbol is to be placed.
symbol FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
See Also