ParameterUtils Class


Parameter Utils Class

A utility class of functions related to parameters.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ParameterUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class ParameterUtils

The ParameterUtils type exposes the following members.

Methods
Name Description
Public method Static member DownloadCompanyName Downloads the name of the given parameter's owning account and records it in the given document. If the owning account's name is already recorded in the given document, this method returns the name without downloading it again.
Public method Static member DownloadParameter Create a shared parameter element in the given document according to a parameter definition downloaded from the Parameters Service.
Public method Static member DownloadParameterOptions Retrieves settings associated with the given parameter from the Parameters Service.
Public method Static member GetAllBuiltInGroups Gets the identifiers of all built-in parameter groups.
Public method Static member GetAllBuiltInParameters Gets the identifiers of all built-in parameters.
Public method Static member GetBuiltInParameter Gets the BuiltInParameter value corresponding to built-in parameter identified by the given ForgeTypeId.
Public method Static member GetParameterTypeId Gets the ForgeTypeId identifying the built-in parameter corresponding to the given BuiltInParameter value.
Public method Static member IsBuiltInGroup Checks whether a ForgeTypeId identifies a built-in parameter group.
Public method Static member IsBuiltInParameter(ElementId) Checks whether an ElementId identifies a built-in parameter.
Public method Static member IsBuiltInParameter(ForgeTypeId) Checks whether a ForgeTypeId identifies a built-in parameter.
Top
See Also