SecondaryDistributionSystem Property


Analytical Transformer Data Secondary Distribution System Property

The secondary distribution system of the analytical transformer.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ElementId SecondaryDistributionSystem { get; set; }

Property Value

ElementId
Exceptions
Exception Condition
ArgumentException When setting this property: The id is neither a distribution system id nor InvalidElementId. -or- When setting this property: The secondary distribution system id can't be set to the analytical transformer.
ArgumentNullException When setting this property: A non-optional argument was null
Remarks
In the case of a transformer, it's crucial that the number of phases in the secondary distribution system matches that of the primary distribution system. If the number of phases in the secondary system is set to be different from that of the primary distribution system, it will result in a 'SecondaryNumOfPhasesNotEqualWithPrimary' error. If you anticipate this discrepancy, you can avoid the error by first setting the secondary distribution system to InvalidElementId, and then setting the primary distribution system.
See Also