SaveAs Method (String, SaveAsOptions)


Document Save As(String, Save As Options) Method

Saves the document to a given file path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public void SaveAs(
	string filepath,
	SaveAsOptions options
)

Parameters

filepath String
File name and path to be saved as. Either a relative or absolute path can be provided.
options SaveAsOptions
Options to govern the SaveAs operation.
Exceptions
Exception Condition
ArgumentException filepath is an empty string. -or- The specified filepath is invalid. -or- options.PreviewViewId is not valid for generation of a preview. -or- The document is not workshared, so no WorksharingSaveAsOptions are allowed to be set for SaveAs. -or- The document just had worksharing enabled or was opened detached, so WorksharingSaveAsOptions.SaveAsCentral must be set to true for SaveAs. -or- Revit cannot clear the transmitted flag. This is not a transmitted document.
ArgumentNullException A non-optional argument was null
CentralModelException Central model is missing. -or- Central model is incompatible. -or- The central model was saved in a different version of Revit. -or- Revit encountered errors while saving to the new central model. Resave again as a new central model. -or- Incompatible servers for external services. -or- Username does not match the one used to create the local file. -or- Revit could not save all of the worksets that have been changed. Try again.
FileAccessException The file at the given path location could not be accessed or saved.
FileNotFoundException The given file, path or network location could not be found during save.
ForbiddenForDynamicUpdateException SaveAs may not be called during dynamic update.
InsufficientResourcesException This computer does not have enough memory, disk space, or other necessary resource to save the model.
InvalidOperationException This Document is not a primary document, it is a linked document. -or- SaveAs is temporarily disabled. -or- options.overwriteExistingFile is 'false' but there is an existing file at filepath. -or- options.overwriteExistingFile is 'true' but the target file at filepath is read only. -or- Saving is not allowed in the current application mode. -or- Operation is not permitted when there is any open sub-transaction, transaction, or transaction group. -or- Revit cannot clear the transmitted flag. This is not a transmitted document. -or- Saving failed.
OperationCanceledException Saving was canceled by the user or by an API event callback.
OutdatedDirectlyOpenedCentralException Other users have modified the central model while you had it opened. Resave your document as a local file and then synchronize with central again.
Remarks

This method may not be called unless all transactions, sub-transactions, and transaction groups that were opened by the API code were closed. That also implies that this method cannot be called during dynamic updates. Event handlers are not allowed to save document that are currently in modifiable state.

If options.rename is true, then the document's title in Revit's title bar will be updated automatically to reflect the file's new name.

See Also