FamilyCategory Property


Family Family Category Property

Retrieves or sets a Category object that represents the category or sub category in which the elements ( this family could generate ) reside.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public Category FamilyCategory { get; set; }

Property Value

Category
Exceptions
Exception Condition
ArgumentException Thrown when the input category cannot be assigned to this family.
ArgumentNullException Thrown when the input category is .
Remarks
All category objects can be retrieved from the application by using the Categories property of the Application.Settings object.
See Also