System |
Represents the specific domain requirements for a system-zone used in MEP design.

System Object
Autodesk.Revit.DB.Analysis GenericZoneDomainData
Autodesk.Revit.DB.Mechanical SystemZoneData
Autodesk.Revit.DB.Analysis GenericZoneDomainData
Autodesk.Revit.DB.Mechanical SystemZoneData
Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The SystemZoneData type exposes the following members.

Name | Description | |
---|---|---|
![]() | ZoneEquipmentId | The id of the zone equipment related to the zone. |

Name | Description | |
---|---|---|
![]() ![]() | Create | Creates a new instance of a system-zone data domain class. |

A system-zone is used to specify what parts of a building are served by specific equipment, air systems and water loops without having to physically model them. A system-zone is represented as a GenericZone element with a domain data of type SystemZoneData, which contains specific domain requirements for the purpose of analysis.