ExporterIFCUtils Class


Exporter IFCUtils Class

A class that contains utilities needed to implement Revit's version of the IFC export client application.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.IFC ExporterIFCUtils

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class ExporterIFCUtils

The ExporterIFCUtils type exposes the following members.

Methods
Name Description
Public method Static member AddClippingsToBaseExtrusion
Public method Static member AddValueString Adds a string value to a built-in parameter.
Public method Static member AreSolidsEqual Determines whether two solids are identical, potentially offset from each other.
Public method Static member CanExportWallGeometryAsExtrusion Identifies if the base geometry of the wall can be represented as an extrusion.
Public method Static member CollectGeometryInfo(ExporterIFC, IFCGeometryInfo, GeometryObject, XYZ, Boolean) Collects all the target geometry from the input geometry object and adds it as IFC handles to the IFCInfo.
Public method Static member CollectGeometryInfo(ExporterIFC, IFCGeometryInfo, GeometryObject, XYZ, Boolean, Transform) Collects all the target geometry from the input geometry object and adds it as IFC handles to the IFCInfo.
Public method Static member ComputeAreaOfCurveLoops
Public method Static member ComputeRoofProjectedArea Returns the projected area of the room, unscaled.
Public method Static member ComputeSubcomponents Splits a roof or floor element composed of planar surfaces into a set of roughly vertical extruded loops of uniform depth if possible.
Public method Static member CreateAlternateGUID Creates a GUID for the given element.
Public method Static member CreateGUID Creates a randomized GUID.
Public method Static member CreateProjectLevelGUID Creates a GUID from Revit project for given GUIDType.
Public method Static member CreateSubElementGUID Creates a consistent GUID for an IFC entity related to a Revit element. A "related" sub-element is one that is unique for a given type of element, and can therefore by identified by a simple index value (e.g. PSet_Wall_Common property set for a wall.) The index value 0 is reserved, as this would generate the GUID of the element itself. A listing of known sub-elements is contained in IFCSubElementEnums.cs; it is expected that this list would be maintained up-to-date, instead of passing arbitrary values into this function.
Public method Static member EndExportInternal Use the internal Revit implementation to relate elements at the end of export.
Public method Static member ExportExtrudedSlabOpenings
Public method Static member ExportSlabAsExtrusion
Public method Static member GetAttachedColumns Obtains a list of columns known to Revit as intersecting with this wall.
Public method Static member GetConnectedWalls Obtains the IFC-specific information regarding the connections between this wall and other elements.
Public method Static member GetDoor2DArcsFromFamily Gets the arcs associated with the plan view of a door.
Public method Static member GetElevationProfile Obtains the curve loops which bound the wall's elevation profile.
Public method Static member GetGeometryFromInplaceWall Obtains a special snapshot of the geometry of an in-place wall element suitable for export.
Public method Static member GetGlobal2DDirectionHandles Obtains the handles representing the cardinal directions in 2D.
Public method Static member GetGlobal2DOriginHandle Obtains the handle representing the 2D origin.
Public method Static member GetGlobal3DDirectionHandles Obtains the handles representing the cardinal directions in 3D.
Public method Static member GetGlobal3DOriginHandle Obtains the handle representing the 3D origin.
Public method Static member GetIFCClassName Obsolete.
Obtains the IFC class name associated to the given element for the current export.
Public method Static member GetIFCClassNameByCategory Obsolete.
Obtains the IFC class name associated to a given category id for the current export.
Public method Static member GetIFCType Obsolete.
Obtains the IFC type associated to the given element for the current export.
Public method Static member GetInstanceCutoutFromWall Gets the curve loop corresponding to the hole in the wall made by the instance.
Public method Static member GetLegacyCurtainSubElements Gets the sub elements from a legacy curtain element.
Public method Static member GetLegacyStairOrRampComponents Gets the components of a stair or ramp.
Public method Static member GetLegacyStairsProperties Returns one or more properties for legacy (created in R2012 or before) Stairs.
Public method Static member GetLevelIdByHeight Gets the level if by the height of the element.
Public method Static member GetLoopsFromTopBottomFace Gets the curve loop(s) that represent the bottom or top face of the wall, usable to create an extrusion for the wall geometry.
Public method Static member GetMinSymbolHeight Obtains the minimum height of the given FamilySymbol.
Public method Static member GetMinSymbolWidth Obtains the minimum width of the given FamilySymbol.
Public method Static member GetNumBuildingStoreys Returns the number of non-empty, non-duplicate building stories in the file.
Public method Static member GetOpeningData Gets the openings data from the element.
Public method Static member GetOriginalSymbol Returns the original family symbol of this family instance, before the instance is modified by joins, cuts, coping, extensions, or other post-processing.
Public method Static member GetRelativeLocalPlacementOffsetTransform Obtains the relative transform between two IfcLocalPlacement handles.
Public method Static member GetRoofComponents Gets the components of roof slabs.
Public method Static member GetRoomBoundaryAsCurveLoopArray Obtains the spatial element boundary curves as an array of CurveLoops, needed for processing into IFC-specific elements later.
Public method Static member GetTransformForDoorOrWindow Obtains the transform for the door or window instance.
Public method Static member GetUnscaledTransform Obtains the unscaled transform from an IfcLocalPlacement handle.
Public method Static member GetUnscaledTransformWithoutFixOfDirection Obtains the unscaled transform from an IfcLocalPlacement handle without fix of direction.
Public method Static member GetWallBaseOffset Obtains the base offset of the wall.
Public method Static member GetWallTrimmedCurve Obtains the curve of the wall trimmed or extended according to the end conditions of the wall.
Public method Static member HasElevationProfile Identifies if the wall has a sketched elevation profile.
Public method Static member IsCurveFromOtherElementSketch Identifies if the given curve element is generated by another element's sketch, or if it represents an independent curve element accessible directly by the user.
Public method Static member IsCurveLoopConvexWithOpenings Checks if the region bounded by the input curve loop can be represented as the subtraction of 0 or more convex polygons from a base convex polygon.
Public method Static member IsWallBaseRectangular Identifies if the wall's base can be represented by a direct thickening of the wall's base curve.
Public method Static member IsWallCompletelyClipped Determines if the input wall is completely removed by interaction with other elements within the given range.
Public method Static member IsWallJoinedToTop Checks if wall is joined to top.
Public method Static member SetGlobal2DDirectionHandles Sets the handles representing the cardinal directions in 2D.
Public method Static member SetGlobal2DOriginHandle Sets the handle representing the 2D origin.
Public method Static member SetGlobal3DDirectionHandles Sets the handles representing the cardinal directions in 3D.
Public method Static member SetGlobal3DOriginHandle Sets the handle representing the 3D origin.
Public method Static member SortCurveLoops
Public method Static member TransformAndScalePoint Converts a point from global Revit coordinates to current IFC coordinates, including scale.
Public method Static member TransformAndScaleVector Converts a vector from global Revit coordinates to current IFC coordinates, including scale.
Public method Static member UsesInstanceGeometry Identifies if the family instance has its own geometry, or uses the symbol's geometry with a transform.
Public method Static member ValidateCurveLoops
Top
Remarks
This class contains special API utilities needed to enable the implementation of the client application for IFC export. Some of these utilities will be needed temporarily while the code for IFC export is migrated into the export client. These temporary interfaces are likely to change in upcoming Revit releases.
See Also