TrussCurveType Property


Model Curve Truss Curve Type Property

The truss curve type of this model curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public TrussCurveType TrussCurveType { get; set; }

Property Value

TrussCurveType
Exceptions
Exception Condition
ArgumentOutOfRangeException Thrown when the assigned value for TrussCurveType is invalid.
InvalidOperationException Thrown when attempting to set this property to a curve not in a truss family.
InvalidOperationException Thrown when attempting to change truss curves to NonTrussCurve, or when the truss curve type may not be applied to curves of this shape (webs must be linear, and chords must be linear or arc).
Remarks
This property is applicable only to curves in Truss families.
See Also