Create Method (XYZ, XYZ, XYZ)


Arc Create(XYZ, XYZ, XYZ) Method

Creates a new geometric arc object based on three points.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static Arc Create(
	XYZ end0,
	XYZ end1,
	XYZ pointOnArc
)

Parameters

end0 XYZ
The start point of the arc.
end1 XYZ
The end point of the arc.
pointOnArc XYZ
A point on the arc.

Return Value

Arc
The new arc.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was NULL
ArgumentsInconsistentException The vectors end0 and end1 are coincident. -or- The vectors end0 and pointOnArc are coincident. -or- The vectors end1 and pointOnArc are coincident. -or- Cannot create an arc. -or- Curve length is too small for Revit's tolerance (as identified by Application.ShortCurveTolerance).
See Also