Temporary |
Tests whether a temporary view mode is currently enabled in the associated view.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- mode TemporaryViewMode
- The mode to evaluate
Return Value
BooleanTrue if the requested mode is available and enabled in the associated view; False otherwise.

Exception | Condition |
---|---|
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |

Most of temporary modes are enabled in a specific context only. A programmer who wants to use a mode needs to first test whether it is currently available and enabled, or not.