View |
Sets the section box for this 3D view.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)

Parameters
- boundingBoxXYZ BoundingBoxXYZ
- The bounding box to use for the section box. To turn off the section box, set IsSectionBoxActive to false. Individual bound enabled flags in the input box are ignored.

Exception | Condition |
---|---|
ArgumentException | Bounding box cannot be empty. |
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | Returns true if the view is not a view template. |