SetBearerExtension Method


Fabrication Rod Info Set Bearer Extension Method

Sets the bearer extension. The method is applicable only for bearer hanger.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetBearerExtension(
	int rodIndex,
	double length
)

Parameters

rodIndex Int32
The index of the rod.
length Double
The new length of bearer extension.
Exceptions
Exception Condition
ArgumentOutOfRangeException the index rodIndex is should be in range of rod count.
InvalidOperationException The hanger is not a bearer hanger.
See Also