Structural |
Sets values for loads display scaling by providing two load forces and their corresponding length of the representative lines in internal units.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public void SetValuesForLoadsDisplayScaling(
double minimumLoadValue,
double minimumForceLineLength,
double maximumLoadValue,
double maximumForceLineLength
)
Parameters

Exception | Condition |
---|---|
ArgumentsInconsistentException | Thrown when: - forces are negative. - line lengths are negative. - minimum force is greater or equal to the maximum force. - line length for minimum force is greater than line length for maximum force. |

Use UnitUtils class methods to convert value from or to internal units. The values are used to scale the representation of all load types(point, line and area loads).