RebarShapeConstraintFixedSegmentDir Constructor


Rebar Shape Constraint Fixed Segment Dir Constructor

Create a fixed segment direction constraint.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public RebarShapeConstraintFixedSegmentDir(
	UV dir
)

Parameters

dir UV
A fixed direction in UV-space.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException dir has zero length.
See Also