IndependentTag Class


Independent Tag Class

Represents tag annotations in Revit. getBBoxCorers in MultipleAlignmentHelper needs access to some protected members.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class IndependentTag : Element

The IndependentTag type exposes the following members.

Properties
Name Description
Public property HasLeader Identifies if a tag has at least one visible leader, or if all leaders are hidden.
Public property IsMaterialTag Identifies if it is a material tag or not.
Public property IsMulticategoryTag Identifies if it is a multi-category tag or not.
Public property IsOrphaned Identifies if the tag is orphaned or not.
Public property LeaderEndCondition The leader end condition of the tag, such as if the end of the leader is attached to the host or free floating.
Public property LeadersPresentationMode Identifies the Presentation Mode that is applied to tag leaders.
Public property MergeElbows Identifies if the leaders' elbows are merged or not. If they are are merged, all elbows are in the same point and they move together.
Public property MultiLeader Returns if the tag if referencing multiple elements and/or sub-elements.
Public property MultiReferenceAnnotationId The multi-reference annotation which owns this tag.
Public property RotationAngle The rotation angle of the tag relative to its view
Public property TagHeadPosition The position of the head of tag in model coordinates.
Public property TagOrientation The tag orientation of the tag's head, such as horizontal or vertical.
Public property TagText The text associated with the tag. If there are several strings assiciated with the tag, the strings will be returned concatenated.
Top
Methods
Name Description
Public method AddReferences
Public method CanLeaderEndConditionBeAssigned Checks whether the LeaderEndCondition can be changed.
Public method Static member Create(Document, ElementId, ElementId, Reference, Boolean, TagOrientation, XYZ) Places a tag on an element or subelement.
Public method Static member Create(Document, ElementId, Reference, Boolean, TagMode, TagOrientation, XYZ) Places a tag on an element or subelement.
Public method GetLeaderElbow Returns the position of the elbow of the tag's leader that points to specified reference. Position of leader's elbow.
Public method GetLeaderEnd Returns the end position of the tag's leader that points to specified reference.
Public method GetTaggedElementIds Returns a set of LinkElementId for all tagged elements, if any. A LinkElementId will be provided for each subelement that is being referenced by the tag.
Public method GetTaggedLocalElementIds Returns a set of IDs for all tagged local elements, if any. A local element ID will be provided for each subelement that is being referenced by the tag. Set of all the element ids in the local file. For each subelement a local element id will be provided.
Public method GetTaggedLocalElements Get the tagged local elements, if any. An Element will be provided for each subelement that is being referenced by the tag.
Public method GetTaggedReferences Get the host references of the tag. An array of all the tagged references.
Public method HasLeaderElbow Whether the tag's leader that points to the reference has an elbow point or not.
Public method HasTagBehavior Checks if the IndependentTag has a tag behavior.
Public method HasTagText Checks if the IndependentTag has a valid tag text.
Public method IsLeaderVisible Returns if leader that points to specified reference is visible or not.
Public method IsTaggedOnSubelement Returns true if the any of the tagged references is a subelement.
Public method RemoveReferences
Public method SetIsLeaderVisible Set tag's leader that points to specified reference to be visible or not. This option can be set only if the LeadersPresentationMode is ShowSpecificLeaders.
Public method SetLeaderElbow Set the position of the elbow of the tag's leader that points to specified reference. If this tag is a multileader tag and the elbows are merged, the input position will be set to all leaders.
Public method SetLeaderEnd Set the end position of the tag's leader that points to specified reference.
Top
Remarks
IndependentTag represents single-category tags, multi-category tags, material tags, and zone tags. IndependentTag is also the base class for other annotations like keynote tags and span symbols. Room, area and space tags are not derived from IndependentTag. SpatialElementTag for more information.
See Also