TreadNosingPosition Property


Stairs Run Type Tread Nosing Position Property

Represents on which edges of the nosing to apply the nosing profile.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public TreadNosingPosition TreadNosingPosition { get; set; }

Property Value

TreadNosingPosition
Exceptions
Exception Condition
ArgumentOutOfRangeException When setting this property: A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException When setting this property: The run type has no tread so the data being set is not applicable.
See Also