Create Method (Plane, Double, Double, Double)


Arc Create(Plane, Double, Double, Double) Method

Creates a new geometric arc object based on plane, radius, and angles.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static Arc Create(
	Plane plane,
	double radius,
	double startAngle,
	double endAngle
)

Parameters

plane Plane
The plane which the arc resides. The plane's origin is the center of the arc.
radius Double
The radius of the arc.
startAngle Double
The start angle of the arc (in radians).
endAngle Double
The end angle of the arc (in radians).

Return Value

Arc
The new arc.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was NULL
ArgumentOutOfRangeException The given value for radius must be greater than 0 and no more than 30000 feet.
ArgumentsInconsistentException Start angle must be less than end angle. -or- Curve length is too small for Revit's tolerance (as identified by Application.ShortCurveTolerance).
Remarks
If the angle range is equal to or greater than 2 * PI, the curve will be automatically converted to an unbounded circle.
See Also