WallSweepInfo Constructor (Boolean, WallSweepType)


Wall Sweep Info(Boolean, Wall Sweep Type) Constructor

Constructs a new WallSweepInfo instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public WallSweepInfo(
	bool fixed,
	WallSweepType type
)

Parameters

fixed Boolean
True if the WallSweepInfo should be fixed (suitable for use in CompoundStructure.AddWallSweep()). False if the WallSweepInfo should be suitable for use in standalone wall sweep or reveal elements.
type WallSweepType
The type of the WallSweepInfo instance.
Exceptions
Exception Condition
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
See Also