VisibleInViewFilter Constructor (Document, ElementId)


Visible In View Filter(Document, Element Id) Constructor

Constructs a new instance of a VisibleInViewFilter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public VisibleInViewFilter(
	Document document,
	ElementId viewId
)

Parameters

document Document
The document that owns the view.
viewId ElementId
The view id.
Exceptions
Exception Condition
ArgumentException viewId is not a view. -or- viewId is not valid for element iteration, because it has no way of representing drawn elements. Many view templates will fail this check.
ArgumentNullException A non-optional argument was null
See Also