CombineWithPrevious Method


Revision Combine With Previous Method

Combines the specified Revision with the previous Revision.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static ISet<ElementId> CombineWithPrevious(
	Document document,
	ElementId revisionId
)

Parameters

document Document
The Document containing the Revisions.
revisionId ElementId
The Revision that should have its clouds and tags associated with the previous Revision.

Return Value

ISet ElementId
The ids of all RevisionClouds that were reassigned to the previous Revision.
Exceptions
Exception Condition
ArgumentException revisionId is not a valid Revision. -or- This operation cannot be performed because revisionId is an issued Revision. -or- revisionId cannot be combined with the previous Revision because either revisionId is the first Revision or the previous Revision has already been issued.
ArgumentNullException A non-optional argument was null
Remarks
All RevisionClouds and tags associated with the specified Revision will be reassigned to the previous Revision in the model and the specified Revision will be deleted from the model. The operation can only be performed if both the specified Revision and the previous one are unissued.
See Also