ExportLayerTable Class


Export Layer Table Class

A table supporting a mapping of category and subcategory to layer name and other layer properties that will be set in the target export format.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ExportLayerTable

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ExportLayerTable : IEnumerable<KeyValuePair<ExportLayerKey, ExportLayerInfo>>, 
	IDisposable

The ExportLayerTable type exposes the following members.

Constructors
Name Description
Public method ExportLayerTable Constructs a new ExportLayerTable with default values.
Top
Properties
Name Description
Public property Count Count of the items contained in the collection.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property Item A copy of the ExportLayerInfo item that corresponds to the layer's ExportLayerKey .
Top
Methods
Name Description
Public method Add Inserts a (key,info) pair into Export layer table.
Public method Clear Removes all contents stored in the table.
Public method ContainsKey Checks whether a layer key exists in the table.
Public method Dispose Releases all resources used by the ExportLayerTable
Public method Static member GetAvaliableLayerModifierTypes Gets all the avaliable layer modifier types for the layer key.
Protected method GetBasicIEnumerator Returns an enumerator that iterates through a collection.
Public method GetEnumerator Returns an enumerator that iterates through a collection.
Public method GetExportLayerInfo Gets a copy of the layer info associated to the input pattern key.
Public method GetKeys Gets all the keys stored in the map.
Public method GetLayerTableIterator Returns a LayerTableIterator that iterates through the collection.
Public method GetValues Returns all the values stored in the map.
Public method Remove Removes the pair (key, info) by pattern key.
Top
Remarks

This table is structured as a mapping from ExportLayerKey to ExportLayerInfo members. The ExportLayerKey contains the identification information for the layer table: the Revit category and subcategory names. In addition, the key contains a SpecialType member used only to represent non-Revit categories that can be assigned specific layer information on export. The ExportLayerInfo contains the exported layer name, color name, and layer modifiers for standard and cut representations.

The table can be accessed via direct iteration as a collection of KeyValuePairs, or by traversal of the stored keys obtained from GetKeys(), or via specific lookup of a key constructed externally. In all cases, the ExportLayerInfo returned will be a copy of the ExportLayerInfo from the table. In order to make changes to the ExportLayerInfo and use those settings during export, set the modified ExportLayerInfo back into the table using the same key.

See Also