Rise |
This enumeration corresponds to the rise/drop symbol used in mechanical systems
Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)


Member name | Value | Description |
---|---|---|
Backslash | 6 | Duct return rise/drop with \ pattern |
BackslashFilled | 7 | Duct return rise/drop with \ pattern and lower left \ is filled |
BendFullCircle | 14 | Pipe 1 Line bend full circle |
BendThreeQuarterCircle | 13 | Pipe 1 Line bend 3/4 circle |
Cross | 2 | Duct supply rise/drop with X pattern |
CrossFilled | 3 | Duct supply rise/drop with X pattern and top and bottom of X is filled |
CrossNoOutline | 17 | Cable Tray 1 Line a cross without outline |
CustomSymbol | -1 | A userdefined symbol for rise/drop graphics is used |
NoSymbol | 0 | No rise/drop graphics will be used |
Outline | 1 | Outline only no internal geometry |
OutlineFilled | 10 | Outline only no internal geometry and filled to be solid |
ReverseWye | 9 | Duct exhaust rise/drop with /\ pattern |
ReverseWyeFilled | 19 | Duct exhaust rise/drop with /\ pattern and lower right \ is filled |
Slash | 4 | Duct return rise/drop with / pattern |
SlashFilled | 5 | Duct return rise/drop with / pattern and lower right / is filled |
TeeFullCircle | 16 | Pipe 1 Line junction full circle |
TeeHalfCircle | 15 | Pipe 1 Line junction 1/2 circle on each side |
Wye | 8 | Duct exhaust rise/drop with \/ pattern |
WyeFilled | 18 | Duct exhaust rise/drop with \/ pattern and lower left / is filled |
YinYang | 11 | Pipe contour rise/drop and 2 half circles (yin-yang) |
YinYangFilled | 12 | Pipe contour rise/drop and 2 half circles (yin-yang) left side is filled |