SchemaBuilder Class


Schema Builder Class

This class is used to create Schemas in the Extensible Storage framework.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.ExtensibleStorage SchemaBuilder

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class SchemaBuilder : IDisposable

The SchemaBuilder type exposes the following members.

Constructors
Name Description
Public method SchemaBuilder Constructs a new SchemaBuilder where the resulting Schema will use the input GUID.
Top
Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method AcceptableName Checks whether a string is an acceptable name for a Schema or a Field.
Public method AddArrayField Creates a field containing an array of values in the Schema, with given name and type of contained values.
Public method AddMapField Creates a field containing an ordered key-value map in the Schema, with given name and type of contained values.
Public method AddSimpleField Creates a field containing a single value in the Schema, with given name and type.
Public method Dispose Releases all resources used by the SchemaBuilder
Public method Finish Registers and returns the created Schema object.
Public method Static member GUIDIsValid Checks whether the supplied GUID value is valid.
Public method Ready Checks whether the builder may be used.
Public method SetApplicationGUID Sets the GUID of the application or add-in that may access entities of this Schema under the Application acess level.
Public method SetDocumentation Sets the documentation string for the Schema.
Public method SetReadAccessLevel Sets top level read access (for entities)
Public method SetSchemaName Sets the name of the Schema.
Public method SetVendorId Sets the ID of the third-party vendor that may access entities of this Schema under the Vendor acess level, and to generally identify the owner of this Schema.
Public method SetWriteAccessLevel Sets top level write access (for entities)
Public method Static member VendorIdIsValid Checks whether the given vendor ID string is valid. A valid vendor ID string: 1. Has a length of at least 4 characters and no more than 253 characters, and 2. Contains only letters, digits, or any of the following special characters: ! " # & \ ( ) + , . - : ; < = > ? _ ` | ~
Top
Remarks
Named parameter idiom: Methods that set up the Schema return a reference to the builder so you can invoke multiple methods in a chain (e.g., builder.setReadAccessLevel(...).setWriteAccessLevel(...)). Methods that add fields return a FieldBuilder instead.
See Also