NewAreaBoundaryConditions Method (Element, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double)


Document New Area Boundary Conditions(Element, Translation Rotation Value, Double, Translation Rotation Value, Double, Translation Rotation Value, Double) Method

Creates a new Area BoundaryConditions element on a host element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public BoundaryConditions NewAreaBoundaryConditions(
	Element hostElement,
	TranslationRotationValue X_Translation,
	double X_TranslationSpringModulus,
	TranslationRotationValue Y_Translation,
	double Y_TranslationSpringModulus,
	TranslationRotationValue Z_Translation,
	double Z_TranslationSpringModulus
)

Parameters

hostElement Element
A Wall, Slab or Slab Foundation to host the boundary conditions.
X_Translation TranslationRotationValue
A value indicating the X axis translation option.
X_TranslationSpringModulus Double
Translation Spring Modulus for X axis. Ignored if X_Translation is not "Spring".
Y_Translation TranslationRotationValue
A value indicating the Y axis translation option.
Y_TranslationSpringModulus Double
Translation Spring Modulus for Y axis. Ignored if Y_Translation is not "Spring".
Z_Translation TranslationRotationValue
A value indicating the Z axis translation option.
Z_TranslationSpringModulus Double
Translation Spring Modulus for Z axis. Ignored if Z_Translation is not "Spring".

Return Value

BoundaryConditions
If successful, NewAreaBoundaryConditions returns an object for the newly created BoundaryConditions with the BoundaryType = 2 - "Area". is returned if the operation fails.
Exceptions
Exception Condition
ArgumentException Thrown if the host element does not exist in the given document.
Remarks
This method will only function with the Autodesk Revit Structure application.
See Also