NewArea Method


Document New Area Method

Creates a new area

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public Area NewArea(
	ViewPlan areaView,
	UV point
)

Parameters

areaView ViewPlan
The view of area element.
point UV
The point which lies in the enclosed region of AreaBoundaryLines to put the new created Area

Return Value

Area
Exceptions
Exception Condition
ArgumentException Thrown if the area view does not exist in the given document.
See Also