Autodesk.Revit.UI Namespace


Autodesk. Revit. UI Namespace

Classes
Class Description
Public class AddInCommandBinding This object represents a binding between a Revit command and one or more handlers which override the behavior of the command in Revit.
Public class ButtonData Base class used to contain information necessary to construct a button in the Ribbon.
Public class ColorSelectionDialog Allows display of the Revit Color dialog.
Public class ComboBox This class represents a selection control with a drop-down list that can be shown or hidden by clicking the arrow.
Public class ComboBoxData This class contains information necessary to construct a combo box in the Ribbon.
Public class ComboBoxMember This class represents an item in the drop-down list of a ComboBox.
Public class ComboBoxMemberData This class contains information necessary to construct a ComboBoxMember.
Public class CommandMenuItem A class representing a single command menu item.
Public class ContextMenu A class that owns context menu items.
Public class ContextualHelp Contains the details for how Revit should allow invocation of contextual help for an item added by an application.
Public class DockablePane A user interface pane that participates in Revit's docking window system.
Public class DockablePaneId Identifier for a pane that participates in the Revit docking window system.
Public class DockablePaneProviderData Information about a new dockable pane being added to the Revit user interface.
Public class DockablePanes Provides a container of all Revit built-in DockablePaneId instances.
Public class DockablePanes BuiltInDockablePanes A collection of ids of the dockable panes provided by Revit.
Public class DockablePaneState Describes where a dockable pane window should appear in the Revit user interface.
Public class DoubleClickOptions Provides access to settings that control what happens when the current user double-clicks on an element.
Public class EditorInteraction Wraps the EditorInteractionType for the Pane to allow for clients to override their type dynamically if need be.
Public class ExternalApplicationArray An array that can contain any number of IExternalApplication objects.
Public class ExternalApplicationArrayIterator An iterator to an array of IExternalApplication objects..
Public class ExternalCommandData A class contains reference to Application and View which are needed by external command.
Public class ExternalCommandsData Base class used to contain external command information necessary to construct PushButtonData and MenuItem.
Public class ExternalEvent A class that represent an external event.
Public class FamilyInstancePlacingArgs The class is used to access necessary data during the placement of a FamilyInstance.
Public class FileDialog Base class supporting display of the dialog used to navigate to and select a file from Autodesk Revit.
Public class FileOpenDialog This class allows an add-in to prompt the user with the Revit dialog used to navigate to and select an existing file path. This dialog is typically used to select a file for opening or importing.
Public class FileSaveDialog This class allows an add-in to prompt the user with the Revit dialog used to navigate to and select an existing or new file path. This dialog is typically used to enter a file name for saving or exporting.
Public class FilterDialog Allows display of the dialog used to create and edit FilterElements in Autodesk Revit.
Public class IFCExternalServiceUIData UI data wrapper for IFCExternalServiceUIData.
Public class ItemData Base class used to contain information necessary to construct RibbonItem and ContextMenuItem
Public class MenuItem An abstract base class that represent a context menu item.
Public class PreviewControl Presents a preview control to browse the Revit model.
Public class ProjectBrowserOptions Provides access to settings that control Revit's Project Browser appearance and functionality.
Public class PromptForFamilyInstancePlacementOptions This class contains options to control the behavior of interactive placement of family instances.
Public class PulldownButton The PulldownButton object represents a button with a drop-down list on RibbonPanel.
Public class PulldownButtonData This class contains information necessary to construct a pulldown button in the Ribbon.
Public class Code example PushButton The PushButton object represents an button on a RibbonPanel.
Public class PushButtonData This class contains information necessary to construct a push button in the Ribbon.
Public class Code example RadioButtonGroup Represents a group of related buttons in the Ribbon.
Public class RadioButtonGroupData This class contains information necessary to construct a ribbon gallery in the Ribbon.
Public class RevisionsOnSheetUIServiceData UI data wrapper for RevisionsOnSheetUIService.
Public class RevitCommandId Represents a command id in Autodesk Revit.
Public class RevitLinkUIUtils A class containing functions for displaying user interface related to Revit links.
Public class RibbonButton This class is the base class of PushButton and PulldownButton.
Public class RibbonButtonOptions A utility class containing the Revit.ini options settings related to ribbon buttons
Public class RibbonItem The RibbonItem object represents an item on RibbonPanel, can be a push-button or a pull-down which should contain the information for creating one RibbonItem.
Public class RibbonItemData Base class used to contain information necessary to construct a RibbonItem in the Ribbon.
Public class Code example RibbonPanel Represents a panel added by an External Application or External Command into the Add-Ins tab.
Public class SelectionUIOptions Provides access to user settings related to how selection will behave in Revit's UI.
Public class SeparatorItem A class representing a context menu separator.
Public class Code example SplitButton The SplitButton object represents a button with a clickable button appearing above a pulldown.
Public class SplitButtonData This class contains information necessary to construct a split button in the Ribbon.
Public class SubMenuItem A class representing a menu flyout.
Public class TabbedDialogExtension Contains the information required to create and implement the behavior for the new tab inside the Revit options dialog.
Public class TableViewUIUtils This utility class contains members that involve the Revit UI and operate on schedule views or MEP electrical panel schedules.
Public class Code example TaskDialog A task dialog is a dialog box that can be used to display information and receive simple input from the user. It has a common set of controls that are arranged in a standard order to assure consistent look and feel.
Public class TemporaryGraphicsCommandData The context data that can be provided to OnClick(TemporaryGraphicsCommandData) .
Public class TextBox The TextBox object represents text-based control that allows the user to enter text.
Public class TextBoxData This class contains information necessary to construct a text box in the Ribbon.
Public class Code example TextEditorOptions Provides access to settings that control Revit's Text Editor appearance and functionality.
Public class ThinLinesOptions A utility class containing setting related to the Thin Lines option which affects the display in the UI.
Public class ToggleButton The ToggleButton object represents a button that has been added to a RadioButtonGroup.
Public class ToggleButtonData This class contains information necessary to construct a toggle button in a RadioButtonGroup.
Public class UIApplication Represents an active session of the Autodesk Revit user interface, providing access to UI customization methods, events, the main window, and the active document.
Public class UIControlledApplication Represents the Autodesk Revit user interface, providing access to UI customization methods and events.
Public class UIDocument An object that represents an Autodesk Revit project opened in the Revit user interface.
Public class UIFabricationUtils General Fabrication UI utility methods in Revit UI.
Public class UISaveAsOptions This class contains UI options available for saving a document to disk with a new filename.
Public class UIThemeManager Manager object for the UITheme class.
Public class UIView A class containing data about view windows in the Revit user interface.
Interfaces
Interface Description
Public interface IContextMenuCreator Interface class for Context Menu creation.
Public interface IControllableDropHandler An interface to be executed when custom data is dragged and dropped onto the Revit user interface. This interface is different from IDropHandler in that it allows the handler to verify whether the drop event can be executed on the given view.
Public interface Code example IDockablePaneProvider Interface that the Revit UI will call during initialization of the user interface to gather information about add-in dockable pane windows.
Public interface IDropHandler An interface to be executed when custom data is dragged and dropped onto the Revit user interface.
Public interface IExternalApplication An interface that supports addition of external applications to Revit.
Public interface Code example IExternalCommand An interface that should be implemented to provide the implementation for a Revit add-in External Command.
Public interface Code example IExternalCommandAvailability An interface that should be implemented to provide the implementation for a accessibility check for a Revit add-in External Command.
Public interface IExternalEventHandler An interface to be executed when an external event is raised.
Public interface IExternalResourceUIServer The interface used to provide custom handling of UI operations related to external resources.
Public interface Code example IFrameworkElementCreator Interface that the Revit UI will call, if present, to construct the FrameworkElement for the pane.
Public interface IIFCEntityTreeUIServer The interface used to provide UI on IFC Entity selection.
Public interface IRevisionsOnSheetUIServer The interface used to provide UI for sheet's Revisions On Sheet property.
Public interface ITemporaryGraphicsHandler Interface class for external server of TemporaryGraphicsHandlerService .
Delegates
Delegate Description
Public delegate TabbedDialogAction Delegate for tabbed dialog actions, such as OnOK, OnCancel and RestoreDefaults.
Enumerations
Enumeration Description
Public enumeration ContextualHelpType Represents the contextual help type.
Public enumeration DockPosition Which part of the Revit application frame the pane should dock to.
Public enumeration DoubleClickAction Possible actions Revit can take in response to the user double-clicking on an element.
Public enumeration DoubleClickTarget Elements that support double-click in Revit. Note that this is meant to cover cases where the element itself is a double-click target. Individual controls that are targets are handled separately.
Public enumeration EditorInteractionType Defines the type of interactions a pane has with the active editor when it becomes active in the Revit UI.
Public enumeration ExternalEventRequest Represents the possible outcomes of a request for raising an external event.
Public enumeration FaceBasedPlacementType This enumerated type specifies options available for placement of a face-based family instance.
Public enumeration ItemSelectionDialogResult An enumerated type listing the possible responses from a prompted dialog where the user is asked to select one or more items.
Public enumeration PostableCommand Enumerates all of the built-in commands which can be posted by an API application.
Public enumeration Result Informs Autodesk Revit of the status of your application after execution.
Public enumeration RibbonItemType An enumerated type listing all the toolbar item styles.
Public enumeration ScrollbarVisibility Lists all the visibility types of the scrollbar in the preview view.
Public enumeration SketchGalleryOptions Enumerates all the sketch options.
Public enumeration Tab An enumerated type listing static tabs which support addition of panels via the API.
Public enumeration TaskDialogCommandLinkId Enum to specify the Id of CommandLink.
Public enumeration TaskDialogCommonButtons A enumerated type containing the standard buttons available for Task Dialogs.
Public enumeration TaskDialogIcon Standard icons to be used in the task dialog.
Public enumeration TaskDialogResult Enum to specify the task dialog result.
Public enumeration ThemeType The application frame theme Type.
Public enumeration UITheme The application frame theme.