Global |
Returns all global paramters in an ordered array.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- document Document
- Document containing the requested global parameters
Return Value
IList ElementIdAn array of Element Ids of all Global Parameters in the document.

Exception | Condition |
---|---|
ArgumentException | Global parameters are not supported in the given document. A possible cause is that it is not a project document, for global parameters are not supported in Revit families. |
ArgumentNullException | A non-optional argument was null |

The order of the items coresponds to the order at which global parameters appear in Revit UI when shown in the standard Global Parameters dialog. However, the order of parameters is serialized in the document, thus available on the DB level as well.