GetVertex Method


Wire Get Vertex Method

Gets the position of an existing vertex.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public XYZ GetVertex(
	int index
)

Parameters

index Int32
The index of the existing vertex. Should be between 0 and NumberOfVertices .

Return Value

XYZ
The position of the vertex. It is the offset point for the start and end vertex, not the connector point. If the wire connects to one device, it may have offset; otherwise, the start and end vertex is same as the connector point.
Exceptions
Exception Condition
ArgumentException The index should be between 0 and the number of vertices of the wire.
See Also