GetMaterialIdForCurrentExportState Method


Exporter IFC Get Material Id For Current Export State Method

This gets the material id that is associated with the element in the current export state.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ElementId GetMaterialIdForCurrentExportState()

Return Value

ElementId
The material id.
Remarks
Even though there could be several materials associated with the element (set during PushExportState()), unless the element has support for IfcMaterialLayerSet, IFC output will include only this one.
See Also