Analytical |
Checks if contour is valid for this Analytical Surface.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- contour CurveLoop
- The curve loop to be checked.
Return Value
BooleanReturns true if curve loop is ok, false otherwise.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |

This method verifies if the contour is valid for a planar Analytical Surface or for a curved Analytical Panel.