BoundingBoxIsInsideFilter Class


Bounding Box Is Inside Filter Class

A filter used to match elements with a bounding box that is contained by the given Outline.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ElementFilter
Autodesk.Revit.DB ElementQuickFilter
Autodesk.Revit.DB BoundingBoxIsInsideFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class BoundingBoxIsInsideFilter : ElementQuickFilter

The BoundingBoxIsInsideFilter type exposes the following members.

Constructors
Name Description
Public method BoundingBoxIsInsideFilter(Outline) Constructs a new instance of a filter to match elements with a bounding box that is contained by the given Outline.
Public method BoundingBoxIsInsideFilter(Outline, Boolean) Constructs a new instance of a filter to match elements with a bounding box is contained by the given Outline, with the option to invert the filter and match all elements with a bounding box that are not contained by the given Outline.
Public method BoundingBoxIsInsideFilter(Outline, Double) Constructs a new instance of a filter to match elements with a bounding box that is contained by the given Outline.
Public method BoundingBoxIsInsideFilter(Outline, Double, Boolean) Constructs a new instance of a filter to match elements with a bounding box is contained by the given Outline, with the option to invert the filter and match all elements with a bounding box that are not contained by the given Outline.
Top
Properties
Name Description
Public property Tolerance Allows control over the match criteria by using a tolerance in the geometry comparison. It is suggested to use this in cases where trivial differences should be considered when matching elements.
Top
Methods
Name Description
Public method GetBoundingBox Gets the outline being used for this filter.
Top
Remarks
This filter excludes all objects derived from View and objects derived from ElementType. This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.
See Also