RoofComponents Class


Roof Components Class

A class that contains multiple roof slab infos of a roof.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.IFC RoofComponents

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class RoofComponents : IDisposable

The RoofComponents type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property ScaledDepth The depth of the roof slab.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the RoofComponents
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetAreasOfCurveLoops The areas of CurveLoops of roof slabs.
Public method GetCurveLoops The CurveLoops of roof slabs.
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetLoopFaces The faces of the loops of roof slabs.
Public method GetPlaneDirections The plane directions of roof slabs.
Public method GetPlaneOrigins The plane origins of roof slabs.
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
This class contains a series of collections that are all of the same length, and whose nth index corresponds to the nth slab of the roof.
See Also