ConvertModelToSymbolicCurves Method


Document Convert Model To Symbolic Curves Method

Converts a group of ModelCurves to equivalent SymbolicCurves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public SymbolicCurveArray ConvertModelToSymbolicCurves(
	View view,
	ModelCurveArray modelCurves
)

Parameters

view View
The view where the new lines will be created. The lines are projected on the view workplane. The view workplane must be parallel to the view plane. If the lines are not parallel to the view plane, lines are foreshortened and arcs are converted to ellipses. Splines are modified.
modelCurves ModelCurveArray
The model curve array to be converted.

Return Value

SymbolicCurveArray
Exceptions
Exception Condition
ArgumentNullException Thrown when the input argument is .
ArgumentException Thrown when view is invalid to create SymbolicCurves on it.
InvalidOperationException Thrown when current document is a family. Thrown when one or more curves could not be successfully converted, perhaps because some of the input curves could not be projected onto the active workplane of the view.
Remarks
This operation will create new SymbolicCurves with the modelCurves' geometry curves and delete the ModelCurve in the array. If modelCurves are not parallel to the workplane, they will be projected to the workplane and create new SymbolicCurves with the projected curves.
See Also