Create Method


Analytical Link Create Method

Creates a new instance of a AnalyticalLink element between two Hubs.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static AnalyticalLink Create(
	Document doc,
	ElementId type,
	ElementId startHubId,
	ElementId endHubId
)

Parameters

doc Document
Document to which new AnalyticalLink should be added.
type ElementId
AnalyticalLinkType for the new AnalyticalLink.
startHubId ElementId
Hub at start of AnalyticalLink.
endHubId ElementId
Hub at end of AnalyticalLink.

Return Value

AnalyticalLink
The newly created AnalyticalLink instance.
Exceptions
Exception Condition
ArgumentException startHubId is not a valid Hub ID for an AnalyticalLink element. -or- endHubId is not a valid Hub ID for an AnalyticalLink element. -or- Thrown if startHubId or endHubId do not represent ids of Hubs. -or- Thrown if startHubId == endHubId. -or- Thrown if type does not represent an id of an AnalyticalLinkType.
ArgumentNullException A non-optional argument was null
See Also