RebarShapeVertex Class


Rebar Shape Vertex Class

A bend between segments of a rebar shape definition.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Structure RebarShapeVertex

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class RebarShapeVertex : IDisposable

The RebarShapeVertex type exposes the following members.

Properties
Name Description
Public property BendAngle The range of permissible angles at this bend.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property Turn The sense of the turn. The Turn property must be set to Left or Right on each internal vertex before the RebarShapeDefinitionBySegments is used. Default is permissible for the first and last vertex, since they do not correspond to bends.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the RebarShapeVertex
Public method GetConstraints Retrieve the list of constraints associated with this vertex.
Public method SetConstraints
Top
Remarks

A RebarShapeVertex is part of a RebarShapeDefinitionBySegments object. There is one vertex between each pair of adjacent segments, plus one at each end of the overall shape. The end vertices currently are ignored by the shape definition, even if they have constraints.

A bend may have the default radius of the bar type referenced by the Rebar element, or it may have a radius defined by a parameter.

See Also