NewRevolution Method


Family Item Factory New Revolution Method

Add a new Revolution instance into the Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public Revolution NewRevolution(
	bool isSolid,
	CurveArrArray profile,
	SketchPlane sketchPlane,
	Line axis,
	double startAngle,
	double endAngle
)

Parameters

isSolid Boolean
Indicates if the Revolution is Solid or Void.
profile CurveArrArray
The profile of the newly created revolution. This may contain more than one curve loop. Each loop must be a fully closed curve loop and the loops must not intersect. All loops must lie in the same plane. The loop can be a unbound circle or ellipse, but its geometry will be split in two in order to satisfy requirements for sketches used in extrusions.
sketchPlane SketchPlane
The sketch plane for the revolution. The direction of revolution is determined by the normal for the sketch plane.
axis Line
The axis of revolution. This axis must lie in the same plane as the curve loops.
startAngle Double
The start angle of Revolution in radians.
endAngle Double
The end angle of Revolution in radians.

Return Value

Revolution
If creation was successful the new revolution is returned, otherwise an exception with failure information will be thrown.
Exceptions
Exception Condition
ArgumentException Thrown when the input argument-profile-is or empty array.
ArgumentNullException Thrown when the input argument-sketchPlane-is .
ArgumentException Thrown when the input argument-sketchPlane-is an invalid sketch plane.
ArgumentNullException Thrown when the input argument-axis-is .
InvalidOperationException Thrown when creation is attempted in Conceptual Mass, 2D, or other family where revolutions cannot be created.
InvalidOperationException Thrown when the creation failed.
Remarks
This method creates an Revolution in a family document. The Revolution will be rotated the plane of the Revolution profile about the Axis.
See Also