IFCBuiltInCategoryKey Class


IFCBuilt In Category Key Class

A key used to represent an item stored in a template.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB IFCBuiltInCategoryKey

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class IFCBuiltInCategoryKey : IDisposable

The IFCBuiltInCategoryKey type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the IFCBuiltInCategoryKey
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also