CanRebarBeSpliced(Rebar, RebarSpliceOptions, Line, ElementId) Method


Rebar Splice Utils Can Rebar Be Spliced(Rebar, Rebar Splice Options, Line, Element Id) Method

Verifies if the rebar can be spliced with the provided line.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static RebarSpliceError CanRebarBeSpliced(
	Rebar rebar,
	RebarSpliceOptions spliceOptions,
	Line line,
	ElementId viewId
)

Parameters

rebar Rebar
The rebar to be spliced.
spliceOptions RebarSpliceOptions
The RebarSpliceOptions.
line Line
The line to splice the rebar with.
viewId ElementId
Based on the view it will be determined the plane of the line.

Return Value

RebarSpliceError
Will return RebarSpliceError.Success if it's possible to splice with line or other enum value corresponding to the error that occurred.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks

This method uses the view normal in case of a 2D view and the current workplane normal in case of a 3D view.

If the view normal is parallel with the bar plane normal the bounded line will be used to calculate the splice geometries where the bar will be split.

Otherwise, the line will be extended to exceed the bounding box of the bar.

See Also