Failure |
A unique key assigned to each posted failure message

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The FailureMessageKey type exposes the following members.

Name | Description | |
---|---|---|
![]() | FailureMessageKey | Constructs a new FailureMessageKey with default settings. |

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the FailureMessageKey |
![]() | Equals | Determines whether the specified Object is equal to the current Object . (Overrides Object Equals(Object) ) |
![]() | GetHashCode | Gets the integer value of the id as hash code (Overrides Object GetHashCode ) |
![]() | IsEqual | Checks it this key is equal to the other. |
![]() | IsValid | Checks if the failure message key is valid |

Name | Description | |
---|---|---|
![]() ![]() | Equality(FailureMessageKey, FailureMessageKey) | Determines whether two FailureMessageKeys are the same. |
![]() ![]() | Inequality(FailureMessageKey, FailureMessageKey) | Determines whether two FailureMessageKeys are different. |

When a failure message is posted, it gets a unique key assigned and returned to the caller. The key is guaranteed to be unique in the Revit session. The key can be used to unpost (delete) previously posted failure message if it is no longer valid.